#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "((?<!\\)(?:\\\\)*\[(?:\\.|[^\]\[])*)\["
Local $sString = "^(([^<>()[\]\\.,;:\s@\"]+(\.[^<>()[\]\\.,;:\s@\"]+)*)|(\".+\"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$"
Local $sSubst = "$1\\["
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)