using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^([\d\+\-.\/*%()a-z ]*)$";
string input = @"1+2
2x**2/4
2^2
&
__import__(re)
sin(sqrt(x**2+y**2))";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}