re = /^([\d\+\-.\/*%()a-z ]*)$/m
str = '1+2
2x**2/4
2^2
&
__import__(re)
sin(sqrt(x**2+y**2))'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end