// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([\d\+\-.\/*%()a-z ]*)$").unwrap();
let string = "1+2
2x**2/4
2^2
&
__import__(re)
sin(sqrt(x**2+y**2))";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}