$re = '/^([\d\+\-.\/*%()a-z ]*)$/m';
$str = '1+2
2x**2/4
2^2
&
__import__(re)
sin(sqrt(x**2+y**2))';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);