import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([\\d\\+\\-.\\/*%()a-z ]*)$";
final String string = "1+2\n"
+ "2x**2/4\n"
+ "2^2\n"
+ "&\n"
+ "__import__(re)\n"
+ "sin(sqrt(x**2+y**2))";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}