const regex = /^([\d\+\-.\/*%()a-z ]*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([\\d\\+\\-.\\\/*%()a-z ]*)$', 'gm')
const str = `1+2
2x**2/4
2^2
&
__import__(re)
sin(sqrt(x**2+y**2))`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}