package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([\d\+\-.\/*%()a-z ]*)$`)
var str = `1+2
2x**2/4
2^2
&
__import__(re)
sin(sqrt(x**2+y**2))`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}