using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Cre.*?\.t\d\.\d";
string input = @"[b'\t\t\t\t\t\t\t\t<td><a href=info.php?id=Cre35.g759247.t1.1+ target=""_blank"">Cre35.g759247.t1.1 </a></td>']
[b'\t\t\t\t\t\t\t\t<td><a href=info.php?id=Cre17.g739850.t1.2 target=""_blank"">Cre17.g739850.t1.2</a></td>']
[b'\t\t\t\t\t\t\t\t<td><a href=info.php?id=Cre17.g737200.t1.2 target=""_blank"">Cre17.g737200.t1.2</a></td>']";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}