import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "Cre.*?\\.t\\d\\.\\d";
final String string = "[b'\\t\\t\\t\\t\\t\\t\\t\\t<td><a href=info.php?id=Cre35.g759247.t1.1+ target=\"_blank\">Cre35.g759247.t1.1 </a></td>']\n"
+ "[b'\\t\\t\\t\\t\\t\\t\\t\\t<td><a href=info.php?id=Cre17.g739850.t1.2 target=\"_blank\">Cre17.g739850.t1.2</a></td>']\n"
+ "[b'\\t\\t\\t\\t\\t\\t\\t\\t<td><a href=info.php?id=Cre17.g737200.t1.2 target=\"_blank\">Cre17.g737200.t1.2</a></td>']";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}