import Foundation
let pattern = #"Cre.*?\.t\d\.\d"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
[b'\t\t\t\t\t\t\t\t<td><a href=info.php?id=Cre35.g759247.t1.1+ target="_blank">Cre35.g759247.t1.1 </a></td>']
[b'\t\t\t\t\t\t\t\t<td><a href=info.php?id=Cre17.g739850.t1.2 target="_blank">Cre17.g739850.t1.2</a></td>']
[b'\t\t\t\t\t\t\t\t<td><a href=info.php?id=Cre17.g737200.t1.2 target="_blank">Cre17.g737200.t1.2</a></td>']
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)