use strict;
my $str = '[b\'\\t\\t\\t\\t\\t\\t\\t\\t<td><a href=info.php?id=Cre35.g759247.t1.1+ target="_blank">Cre35.g759247.t1.1 </a></td>\']
[b\'\\t\\t\\t\\t\\t\\t\\t\\t<td><a href=info.php?id=Cre17.g739850.t1.2 target="_blank">Cre17.g739850.t1.2</a></td>\']
[b\'\\t\\t\\t\\t\\t\\t\\t\\t<td><a href=info.php?id=Cre17.g737200.t1.2 target="_blank">Cre17.g737200.t1.2</a></td>\']';
my $regex = qr/Cre.*?\.t\d\.\d/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}