package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Cre.*?\.t\d\.\d`)
var str = `[b'\t\t\t\t\t\t\t\t<td><a href=info.php?id=Cre35.g759247.t1.1+ target="_blank">Cre35.g759247.t1.1 </a></td>']
[b'\t\t\t\t\t\t\t\t<td><a href=info.php?id=Cre17.g739850.t1.2 target="_blank">Cre17.g739850.t1.2</a></td>']
[b'\t\t\t\t\t\t\t\t<td><a href=info.php?id=Cre17.g737200.t1.2 target="_blank">Cre17.g737200.t1.2</a></td>']`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}