re = /Cre.*?\.t\d\.\d/m
str = '[b\'\\t\\t\\t\\t\\t\\t\\t\\t<td><a href=info.php?id=Cre35.g759247.t1.1+ target="_blank">Cre35.g759247.t1.1 </a></td>\']
[b\'\\t\\t\\t\\t\\t\\t\\t\\t<td><a href=info.php?id=Cre17.g739850.t1.2 target="_blank">Cre17.g739850.t1.2</a></td>\']
[b\'\\t\\t\\t\\t\\t\\t\\t\\t<td><a href=info.php?id=Cre17.g737200.t1.2 target="_blank">Cre17.g737200.t1.2</a></td>\']'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end