#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(?:div|i)(?:.*?(?:class|data-id)="([^"]+)")?(?:.*?(?:class|data-id)="([^"]+)")?[^>]*>"
Local $sString = "<!-- I want to: $matches[1] == test_class | $matches[2] == null -->" & @CRLF & _
"<div class="test_class"> " & @CRLF & _
"" & @CRLF & _
"<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->" & @CRLF & _
"<div class="test_class" data-id="1"> " & @CRLF & _
"" & @CRLF & _
"<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->" & @CRLF & _
"<div id="test_id" class="test_class" data-id="1">" & @CRLF & _
"" & @CRLF & _
"<!-- I want to: $matches[1] == test_class test_class2 | $matches[2] == 1 -->" & @CRLF & _
"<div class="test_class test_class2" id="test_id" data-id="1">" & @CRLF & _
"" & @CRLF & _
"<!-- I want to: $matches[1] == 1 | $matches[2] == test_class test_class2 -->" & @CRLF & _
"<div data-id="1" class="test_class test_class2" id="test_id" >" & @CRLF & _
"" & @CRLF & _
"<!-- I want to: $matches[1] == 1 | $matches[2] == test_class test_class2 -->" & @CRLF & _
"<div id="test_id" data-id="1" class="test_class test_class2">" & @CRLF & _
"" & @CRLF & _
"<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->" & @CRLF & _
"<div class="test_class" id="test_id" data-id="1">"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")