// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)<(?:div|i)(?:.*?(?:class|data-id)="([^"]+)")?(?:.*?(?:class|data-id)="([^"]+)")?[^>]*>"#).unwrap();
let string = "<!-- I want to: $matches[1] == test_class | $matches[2] == null -->
<div class=\"test_class\">
<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->
<div class=\"test_class\" data-id=\"1\">
<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->
<div id=\"test_id\" class=\"test_class\" data-id=\"1\">
<!-- I want to: $matches[1] == test_class test_class2 | $matches[2] == 1 -->
<div class=\"test_class test_class2\" id=\"test_id\" data-id=\"1\">
<!-- I want to: $matches[1] == 1 | $matches[2] == test_class test_class2 -->
<div data-id=\"1\" class=\"test_class test_class2\" id=\"test_id\" >
<!-- I want to: $matches[1] == 1 | $matches[2] == test_class test_class2 -->
<div id=\"test_id\" data-id=\"1\" class=\"test_class test_class2\">
<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->
<div class=\"test_class\" id=\"test_id\" data-id=\"1\">";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}