const regex = /<(?:div|i)(?:.*?(?:class|data-id)="([^"]+)")?(?:.*?(?:class|data-id)="([^"]+)")?[^>]*>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(?:div|i)(?:.*?(?:class|data-id)="([^"]+)")?(?:.*?(?:class|data-id)="([^"]+)")?[^>]*>', 'gm')
const str = `<!-- I want to: \$matches[1] == test_class | \$matches[2] == null -->
<div class="test_class">
<!-- I want to: \$matches[1] == test_class | \$matches[2] == 1 -->
<div class="test_class" data-id="1">
<!-- I want to: \$matches[1] == test_class | \$matches[2] == 1 -->
<div id="test_id" class="test_class" data-id="1">
<!-- I want to: \$matches[1] == test_class test_class2 | \$matches[2] == 1 -->
<div class="test_class test_class2" id="test_id" data-id="1">
<!-- I want to: \$matches[1] == 1 | \$matches[2] == test_class test_class2 -->
<div data-id="1" class="test_class test_class2" id="test_id" >
<!-- I want to: \$matches[1] == 1 | \$matches[2] == test_class test_class2 -->
<div id="test_id" data-id="1" class="test_class test_class2">
<!-- I want to: \$matches[1] == test_class | \$matches[2] == 1 -->
<div class="test_class" id="test_id" data-id="1">`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}