import re
regex = re.compile(r"<(?:div|i)(?:.*?(?:class|data-id)=\"([^\"]+)\")?(?:.*?(?:class|data-id)=\"([^\"]+)\")?[^>]*>", flags=re.MULTILINE)
test_str = ("<!-- I want to: $matches[1] == test_class | $matches[2] == null -->\n"
"<div class=\"test_class\"> \n\n"
"<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->\n"
"<div class=\"test_class\" data-id=\"1\"> \n\n"
"<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->\n"
"<div id=\"test_id\" class=\"test_class\" data-id=\"1\">\n\n"
"<!-- I want to: $matches[1] == test_class test_class2 | $matches[2] == 1 -->\n"
"<div class=\"test_class test_class2\" id=\"test_id\" data-id=\"1\">\n\n"
"<!-- I want to: $matches[1] == 1 | $matches[2] == test_class test_class2 -->\n"
"<div data-id=\"1\" class=\"test_class test_class2\" id=\"test_id\" >\n\n"
"<!-- I want to: $matches[1] == 1 | $matches[2] == test_class test_class2 -->\n"
"<div id=\"test_id\" data-id=\"1\" class=\"test_class test_class2\">\n\n"
"<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->\n"
"<div class=\"test_class\" id=\"test_id\" data-id=\"1\">")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")