using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(?:div|i)(?:.*?(?:class|data-id)=""([^""]+)"")?(?:.*?(?:class|data-id)=""([^""]+)"")?[^>]*>";
string input = @"<!-- I want to: $matches[1] == test_class | $matches[2] == null -->
<div class=""test_class"">
<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->
<div class=""test_class"" data-id=""1"">
<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->
<div id=""test_id"" class=""test_class"" data-id=""1"">
<!-- I want to: $matches[1] == test_class test_class2 | $matches[2] == 1 -->
<div class=""test_class test_class2"" id=""test_id"" data-id=""1"">
<!-- I want to: $matches[1] == 1 | $matches[2] == test_class test_class2 -->
<div data-id=""1"" class=""test_class test_class2"" id=""test_id"" >
<!-- I want to: $matches[1] == 1 | $matches[2] == test_class test_class2 -->
<div id=""test_id"" data-id=""1"" class=""test_class test_class2"">
<!-- I want to: $matches[1] == test_class | $matches[2] == 1 -->
<div class=""test_class"" id=""test_id"" data-id=""1"">";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}