# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\.(?=[A-Z])/\.\n/gm;t' <<< "Hello World. Hello World.Hello World.Hello World"