$re = '/\.(?=[A-Z])/m';
$str = 'Hello World. Hello World.Hello World.Hello World';
$subst = "\.\n";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;