const regex = new RegExp('\\.(?=[A-Z])', 'gm')
const str = `Hello World. Hello World.Hello World.Hello World`;
const subst = `\.\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);