import re
regex = re.compile(r"\.(?=[A-Z])", flags=re.MULTILINE)
test_str = "Hello World. Hello World.Hello World.Hello World"
subst = "\\.\\n"
result = regex.sub(subst, test_str)
if result:
print(result)