#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\.(?=[A-Z])"
Local $sString = "Hello World. Hello World.Hello World.Hello World"
Local $sSubst = "\.\n"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)