#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^\d{1,2})(th|rd|nd)(\s)(\w+)(\s)(\d{4})"
Local $sString = "12/jan/2023"
Local $sSubst = "\1 \4 \6"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)