import Foundation
let pattern = #"(^\d{1,2})(th|rd|nd)(\s)(\w+)(\s)(\d{4})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"12/jan/2023"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1 \4 \6"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)