package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^\d{1,2})(th|rd|nd)(\s)(\w+)(\s)(\d{4})`)
var str = `12/jan/2023`
var substitution = "\1 \4 \6"
fmt.Println(re.ReplaceAllString(str, substitution))
}