re = /(^\d{1,2})(th|rd|nd)(\s)(\w+)(\s)(\d{4})/m
str = '12/jan/2023'
subst = '\\1 \\4 \\6'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result