#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(\d+(?=\[))\[([^\(\[\{\}\]\)]+)\]"
Local $sString = "//Valid match" & @CRLF & _
"12[red,green],13[xs,xl,xxl]" & @CRLF & _
"number[anythingBut ()[]{},anythingBut ()[]{}](,number[anythingBut ()[]{},anythingBut ()[]{}]) or nothing" & @CRLF & _
"" & @CRLF & _
"//Not valid match" & @CRLF & _
"12[red,green],13[xs,xl,xxl 9974-?ds12[dfgd,dfgd]]"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)