using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+(?=\[))\[([^\(\[\{\}\]\)]+)\]";
string substitution = @"";
string input = @"//Valid match
12[red,green],13[xs,xl,xxl]
number[anythingBut ()[]{},anythingBut ()[]{}](,number[anythingBut ()[]{},anythingBut ()[]{}]) or nothing
//Not valid match
12[red,green],13[xs,xl,xxl 9974-?ds12[dfgd,dfgd]]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}