import Foundation
let pattern = #"(\d+(?=\[))\[([^\(\[\{\}\]\)]+)\]"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
//Valid match
12[red,green],13[xs,xl,xxl]
number[anythingBut ()[]{},anythingBut ()[]{}](,number[anythingBut ()[]{},anythingBut ()[]{}]) or nothing
//Not valid match
12[red,green],13[xs,xl,xxl 9974-?ds12[dfgd,dfgd]]
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)