import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+(?=\\[))\\[([^\\(\\[\\{\\}\\]\\)]+)\\]";
final String string = "//Valid match\n"
+ "12[red,green],13[xs,xl,xxl]\n"
+ "number[anythingBut ()[]{},anythingBut ()[]{}](,number[anythingBut ()[]{},anythingBut ()[]{}]) or nothing\n\n"
+ "//Not valid match\n"
+ "12[red,green],13[xs,xl,xxl 9974-?ds12[dfgd,dfgd]]";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}