use strict;
my $str = '//Valid match
12[red,green],13[xs,xl,xxl]
number[anythingBut ()[]{},anythingBut ()[]{}](,number[anythingBut ()[]{},anythingBut ()[]{}]) or nothing
//Not valid match
12[red,green],13[xs,xl,xxl 9974-?ds12[dfgd,dfgd]]';
my $regex = qr/(\d+(?=\[))\[([^\(\[\{\}\]\)]+)\]/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";