re = /(\d+(?=\[))\[([^\(\[\{\}\]\)]+)\]/
str = '//Valid match
12[red,green],13[xs,xl,xxl]
number[anythingBut ()[]{},anythingBut ()[]{}](,number[anythingBut ()[]{},anythingBut ()[]{}]) or nothing
//Not valid match
12[red,green],13[xs,xl,xxl 9974-?ds12[dfgd,dfgd]]'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result