using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:\D)*(?:(\d{1,3})\/)?(?:(\d{1,3})\/)?(\d{1,3})\/(\d{1,3})$";
string input = @"1/1/1
XDSL 1/1/1/1
XDSL Port 1/1/1/1
Port 1/1/1/1
Anytext 1/1/1/1
XDSL 1/1/1
XDS 1/1
1/1/1/1
ABC 1/1";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}