import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\D)*(?:(\\d{1,3})\\/)?(?:(\\d{1,3})\\/)?(\\d{1,3})\\/(\\d{1,3})$";
final String string = "1/1/1\n"
+ "XDSL 1/1/1/1\n"
+ "XDSL Port 1/1/1/1\n"
+ "Port 1/1/1/1\n"
+ "Anytext 1/1/1/1\n"
+ "XDSL 1/1/1\n"
+ "XDS 1/1\n"
+ "1/1/1/1\n"
+ "ABC 1/1";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}