// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^(?:\D)*(?:(\d{1,3})\/)?(?:(\d{1,3})\/)?(\d{1,3})\/(\d{1,3})$").unwrap();
let string = "1/1/1
XDSL 1/1/1/1
XDSL Port 1/1/1/1
Port 1/1/1/1
Anytext 1/1/1/1
XDSL 1/1/1
XDS 1/1
1/1/1/1
ABC 1/1";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}