const regex = /^(?:\D)*(?:(\d{1,3})\/)?(?:(\d{1,3})\/)?(\d{1,3})\/(\d{1,3})$/igm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:\\D)*(?:(\\d{1,3})\\\/)?(?:(\\d{1,3})\\\/)?(\\d{1,3})\\\/(\\d{1,3})$', 'igm')
const str = `1/1/1
XDSL 1/1/1/1
XDSL Port 1/1/1/1
Port 1/1/1/1
Anytext 1/1/1/1
XDSL 1/1/1
XDS 1/1
1/1/1/1
ABC 1/1`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}