using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\[:fr\](\D*)\[:\]";
string substitution = @"";
string input = @"[:fr] French title [:][:en] English title [:]";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}