import re
regex = re.compile(r"\[:fr\](\D*)\[:\]")
test_str = "[:fr] French title [:][:en] English title [:]"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)