const regex = /\[:fr\](\D*)\[:\]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\[:fr\\](\\D*)\\[:\\]', 'g')
const str = `[:fr] French title [:][:en] English title [:]`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);