$re = '/\[:fr\](\D*)\[:\]/U';
$str = '[:fr] French title [:][:en] English title [:]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;