# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((?<e1>""|'|`)(?:\$\k<e1>|(?!\k<e1>).)*\k<e1>)|\t+/$1/gm;t' <<< "\"\"$\"\"
`$`
`a`
`a`
\"a` `\"
This is a \"\"test test test\"\" and ` test` and 'test ' but one or more tabs test should be removed"