$re = '/((?<e1>""|\'|`)(?:\$\k<e1>|(?!\k<e1>).)*\k<e1>)|\t+/m';
$str = '""$""
`$`
`a`
`a`
"a` `"
This is a ""test test test"" and ` test` and \'test \' but one or more tabs test should be removed';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;