# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"((?<e1>\"\"|'|`)(?:\$\k<e1>|(?!\k<e1>).)*\k<e1>)|\t+"
test_str = ("\"\"$\"\"\n"
"`$`\n"
"`a`\n\n"
" `a`\n"
"\"a` `\"\n\n"
"This is a \"\"test test test\"\" and ` test` and 'test ' but one or more tabs test should be removed")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.