use strict;
my $str = '""$""
`$`
`a`
`a`
"a` `"
This is a ""test test test"" and ` test` and \'test \' but one or more tabs test should be removed';
my $regex = qr/((?<e1>""|'|`)(?:\$\k<e1>|(?!\k<e1>).)*\k<e1>)|\t+/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";