using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?<e1>""|'|`)(?:\$\k<e1>|(?!\k<e1>).)*\k<e1>)|\t+";
string substitution = @"$1";
string input = @"""$""
`$`
`a`
`a`
""a` `""
This is a ""test test test"" and ` test` and 'test ' but one or more tabs test should be removed";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}