const regex = /((?<e1>""|'|`)(?:\$\k<e1>|(?!\k<e1>).)*\k<e1>)|\t+/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?<e1>""|\'|`)(?:\\$\\k<e1>|(?!\\k<e1>).)*\\k<e1>)|\\t+', 'gm')
const str = `""\$""
\`\$\`
\`a\`
\`a\`
"a\` \`"
This is a ""test test test"" and \` test\` and 'test ' but one or more tabs test should be removed`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);