#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)((?<e1>""|'|`)(?:\$\k<e1>|(?!\k<e1>).)*\k<e1>)|\t+"
Local $sString = """$""" & @CRLF & _
"`$`" & @CRLF & _
"`a`" & @CRLF & _
"" & @CRLF & _
" `a`" & @CRLF & _
""a` `"" & @CRLF & _
"" & @CRLF & _
"This is a ""test test test"" and ` test` and 'test ' but one or more tabs test should be removed"
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)