# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\/(?<lang>[a-z]{2})-(?<country>[A-Z]{2})\\///gm;t' <<< "http://example.com/ja-JP/blog/12345"